Object reference not set to an instance of an object

Feb 3, 2009 at 9:09 PM

Great tool.. However I'm running into some problems .. And I'm not sure where to start looking..



D:\>LOS.SP.CleanOrphanedUsers.exe -site http://<server>/applications -recursive
---------------------------------
Site: applications
Removed user: DOMAIN\jhussey
Removed user: DOMAIN\system
Removed user: DOMAIN\kvinot
---------------------------------
List: CS3
---------------------------------
List: fpdatasources
---------------------------------
List: Workflows
---------------------------------
Folder: Customer Service
---------------------------------
Site: tanker
System.NullReferenceException: Object reference not set to an instance of an object.
   at LOS.SP.CleanOrphanedUsers.Program.GetOrphanedUsers(SPFolder folder, UserProfileManager profileManager)
   at LOS.SP.CleanOrphanedUsers.Program.ProcessChildObjects(SPFolder parentFolder, UserProfileManager profileManager)
   at LOS.SP.CleanOrphanedUsers.Program.ProcessFolders(SPList list, UserProfileManager profileManager)
   at LOS.SP.CleanOrphanedUsers.Program.ProcessLists(SPWeb web, UserProfileManager profileManager)
   at LOS.SP.CleanOrphanedUsers.Program.ProcessChildObjects(SPWeb parentWeb, UserProfileManager profileManager)
   at LOS.SP.CleanOrphanedUsers.Program.BeginCleaning()

   at LOS.SP.CleanOrphanedUsers.Program.GetOrphanedUsers(SPFolder folder, UserProfileManager profileManager)
   at LOS.SP.CleanOrphanedUsers.Program.ProcessChildObjects(SPFolder parentFolder, UserProfileManager profileManager)
   at LOS.SP.CleanOrphanedUsers.Program.ProcessFolders(SPList list, UserProfileManager profileManager)
   at LOS.SP.CleanOrphanedUsers.Program.ProcessLists(SPWeb web, UserProfileManager profileManager)
   at LOS.SP.CleanOrphanedUsers.Program.ProcessChildObjects(SPWeb parentWeb, UserProfileManager profileManager)
   at LOS.SP.CleanOrphanedUsers.Program.BeginCleaning()

D:\>

Coordinator
Feb 4, 2009 at 6:13 PM
I just made some updates to this utility and posted the new release. I am hoping this will reslove the issue. If not, can you let me know what type of user objects are in the site giving you problems? Example: domain users, domain groups, sharepoint groups, etc...